halb/halb

Die Installation von Panther auf meinem TiBook lief ja, wie gestern geschrieben, problemlos. Auf meinem iMac leider nicht ganz…

Die erste CD lief ganz normal durch, bis die Anzeige kam, dass das System in 30 Sekunden rebooten würde. Oder eben sofort, wenn man auf den passenden Knopf drückt. Das tat ich, woraufhin der Bildschirm sofort schwarz wurde und der Rechner rebootete. So prompt schwarz werdende Bildschirme beim rebootet sind nicht gut…

Beim booten blieb er beim Apfel stehen, also da, wo einen früher der “smiling Mac” angelächelt hatte. Und weiter kam er nicht. Nach einiger rumprobiererei habe ich kurzerhand nochmals von der CD 1 gebootet und nochmals installiert, bzw. das Update gemacht.

Mittlerweile habe ich ein laufendes Mac OS X 10.3, aber irgendwie hat es, trotz Update, das ja eigentlich alle Konfigurationen bewahren sollte, alles vergessen, das Netzwerk neu konfiguriert und einen neuen User angelegt.

Das Netzwerk war kein Problem, das war schnell konfiguriert.

Der User war trickreicher. Den Braten riechend habe ich einen neuen User mit einem anderen Login als meinem üblichen angelegt. Nach erfolgtem Login habe ich als allererstes im NetInfo Manager den root-User freigeschaltet. Als dieser eingeloggt habe ich dann im NetInfo den neu angelegten User umbenannt. Das Home meines alten Users war ja noch da, mit passenden UIDs und GIDs, nur der alte User war durch die unfreiwillige Neuinstallation aus dem NetInfo verschwunden. Duerch die Umbenennung des neuen Users zu meinem alten passte wieder alles. Nach einen erneuten um-loggen war ich dann endlich wieder zurück zu “normal”.

Schön ist, dass ich durch das Fast User Switching andlich meinen eigenen User aus der Gruppe “Admin” herausnehmen kann, Damit fällt das Risiko, etwas kaputtmachen zu können, schonmal um einiges.

Unschön, dass dieser (vermutliche) Absturz mir etwas Arbeit beschert hat. Aber letztendlich ist nicht viel verschwunden. Durch das Neuanlegen von allem ist allerdings auch der sshd momentan nicht am laufen und so komme ich nicht remote auf meinen Rechner. Naja, bis heute Abend…

Dann werde ich auch Postfix neu konfigurieren müssen. Da Mac OS X von Version 10.2 auf 10.3 von sendmail auf Postfix gewechselt hat, war mir das eh klar, dass ich mein von Hand installiertes Postfix neu konfigurieren darf… Da ich smtp_auth und TLS benutze, ist das schon etwas interessanter… ;-)

Heute Abend dann, zusammen mit dem named und was mir sonst noch so auffällt…

Copyright

Kommentare